Back to overview
Resolved
Database Infrastructure Faililng
Jul 17, 2026 at 10:02am UTC
Affected services
Server
Database
Storage
Resolved
Jul 17, 2026 at 1:11pm UTC
The issue is fixed
Affected services
Updated
Jul 17, 2026 at 10:05am UTC
Monitoring infrastructure
Affected services
Updated
Jul 17, 2026 at 10:04am UTC
We are investigating and implementing a fix
Affected services
Created
Jul 17, 2026 at 10:02am UTC
Database infrastructure is currently failing for all users
Affected services