Back to overview
Degraded

AI Chat, AI Tutor, and 1 other service are down

May 29, 2026 at 6:23am UTC
Affected services
AI Chat
AI Tutor
Pronunciation Coach

Resolved
May 29, 2026 at 7:01pm UTC

AI Chat and AI Tutor recovered.

Updated
May 29, 2026 at 6:42pm UTC

AI Chat and AI Tutor are degraded.

Updated
May 29, 2026 at 8:43am UTC

AI Tutor recovered.

Updated
May 29, 2026 at 8:43am UTC

AI Chat recovered.

Updated
May 29, 2026 at 8:39am UTC

AI Chat and AI Tutor are degraded.

Updated
May 29, 2026 at 7:30am UTC

Pronunciation Coach recovered.

Updated
May 29, 2026 at 6:47am UTC

Pronunciation Coach is degraded.

Updated
May 29, 2026 at 6:33am UTC

Pronunciation Coach recovered.

Created
May 29, 2026 at 6:23am UTC

Pronunciation Coach is degraded.