Back to overview
Degraded
AI Chat, AI Tutor, and 1 other service are down
May 26, 2026 at 2:06am UTC
Affected services
AI Chat
AI Tutor
Pronunciation Coach
Resolved
May 26, 2026 at 11:09pm UTC
Pronunciation Coach recovered.
Affected services
Updated
May 26, 2026 at 10:05pm UTC
Pronunciation Coach is degraded.
Affected services
Updated
May 26, 2026 at 5:25am UTC
AI Tutor recovered.
Affected services
Updated
May 26, 2026 at 5:25am UTC
AI Chat recovered.
Affected services
Created
May 26, 2026 at 2:06am UTC
AI Chat and AI Tutor are degraded.
Affected services