Back to overview
Degraded
Pronunciation Coach is down
Apr 27, 2026 at 9:38am UTC
Affected services
Pronunciation Coach
Resolved
Apr 27, 2026 at 10:07am UTC
Pronunciation Coach recovered.
Affected services
Created
Apr 27, 2026 at 9:38am UTC
Pronunciation Coach is degraded.
Affected services